Splashtop quality awful again

itmanager Member Posts: 5
edited December 3 in General

I have been using splashtop without issue remote controlling my machines for a while and then a couple of days ago the quality of the picture is so bad I can't even read writing properly. I have deleted and re-added the RMM client app on my machine but it's made no difference, I also updated it using the updater with no change. The various options in the RMM client for video have made no difference also. This happened to me last year and then cleared up with remove / reinstall. Any tips on what I can do?


  • tanderson
    tanderson Member Posts: 136 ✭✭✭

    @itmanager Unfortunately, I have never seen this issue, but it sounds more like a connection speed issue than an installation/update issue. Is this just one machine affected or all?

  • itmanager
    itmanager Member Posts: 5

    All machines I connect to - including via local 1Gb LAN! We have a 100Mb ethernet as well and no issues. Using competing remote support applications I have no issues, just splashtop.

  • itmanager
    itmanager Member Posts: 5

    I should add, using a different machine it's working ok. It did prompt me to upgrade on that machine (Splashtop Updater Service) and when I looked at the certificate on the upgrade prompt it expired 7th January 2022! I didn't upgrade from there but ran the app and upgraded straight from there.

  • tanderson
    tanderson Member Posts: 136 ✭✭✭

    @itmanager Can you clarify? When you use a different machine to remote into machines it is fine. Just your main machine is having issues remoting in?

  • m.vincer
    m.vincer Member Posts: 13 ✭✭
    edited July 18

    @itmanager We've had similar issues before but with the addition of occasional disconnects or failure to connect at all.

    Note: Our ISP is a bit funky so this may not directly impact your issue.

    Empty out the HKLM\SOFTWARE\WOW6432Node\Splashtop Inc.\Splashtop Remote Server\CloudRegion key value - just delete whatever is in there and restart the Splashtop services - maybe a full system reboot just for good measure.

    We've deployed this emptying of the CloudRegion key via group policy after testing and haven't had any issues, aside from the typical "degraded service" type stuff you see on the status page.

  • sarah+success
    sarah+success Administrator Posts: 64 admin

    Hey there @itmanager , Sarah from Atera here. While the above comments may have helped, I opened a ticket on your behalf just so that our support can take a look and see how we can assist you.

  • Matthias
    Matthias Member Posts: 56 ✭✭✭

    I had similar problems in the past and I fixed it by opening Splashtop on my computer, then go into Options, chose the 2nd tab (advanced) and then clicked "Advanced Settings".

    A new popup opens in which I can select the rendering method. Here I did switch to "Software".

    Since I did this change the quality issues were gone but sometimes it can happen that the Remopte Session freezes and I need to reopen it again. This does not happen on a daily base so I am OK to live with that :)

  • zach
    zach Member Posts: 2

    we had the same issue with the above settings plus disabling hardware Acceleration in that same menu fixed this exact issue for me

  • CSsysadmin
    CSsysadmin Member Posts: 1

    The video quality is very poor for me as well. This is the first time I have encountered this problem after many years of using.

  • mb
    mb Member Posts: 4

    I gave it a try - but now I use AnyDesk only

  • smcfarland
    smcfarland Member Posts: 1

    Open the Splashtop RMM app, on YOUR PC. This is the required viewer that must be installed on the remote viewer PC. Once open, go to OPTIONS. Once in Options - go to the Advanced Tab. Then select Advanced Settings.

    You will see a drop down menu for Video Rendering Options. Change this drop down to Software. Also, you can check or uncheck Hardware Acceleration. Make subtle changes and try to connect to the remote PC again. See if that resolves your quality issue. That is what worked for me. You may have to try different options for optimal views.

    Also, it goes without saying… update your Splashtop RMM tool. You can do this by selecting, "Check for Updates".

  • sarah+success
    sarah+success Administrator Posts: 64 admin

    Awesome work @smcfarland , this is so helpful!

  • andb
    andb Member Posts: 1

    None of these options worked for me but I found this thread so I thought I'd add my solution. My issue happened the same as described but is much later (11/12/23). The hardware acceleration option is no longer present, but there were 2 checkboxes for 'legacy compaatibility mode,' both of which I disabled. That seems to have fixed it for me.