RingCentral installation Script Issue

Ahanike Member Posts: 3

Having a hard time installing the RingCentral application on any computer through Atera. I have tried using the Software included in Atera software section and it fails. I have written a Script to have it be downloaded and then installed and then another to be downloaded and then installed silently and using the powershell feature in Atera and still fails or the process has timed out when the process is even set to 20 minutes. I gave tested the script out straight from my laptop and it runs fine.

I then try installing other applications through the software area in Atera like Firefox and it installs fine. What could be going on?

Script i created is below:

Define the URL to download the installer

$url = "https://app.ringcentral.com/download"

Define the path where the installer will be saved

$installerPath = "$env:TEMP\RingCentral.exe"

Download the installer silently

Invoke-WebRequest -Uri $url -OutFile $installerPath

Check if the installer file was downloaded successfully

if (Test-Path $installerPath) {
# Start the installation process silently
Start-Process -FilePath $installerPath -ArgumentList "/S" -Wait
Write-Host "Installation completed silently."
} else {
Write-Host "Failed to download the installer from $url. Please check the URL and try again."



  • mbudke
    mbudke Member Posts: 87 ✭✭✭

    I can imagine that this is a permission issue.
    On your computer I guess you run it witth your local user. Since you are an IT person I believe you are having administrative rights.

    When executing it via Atera it runs as SYSTEM which is a different user.There is an option to execute as currently logged in user but then the user requires administrative rights.

  • Ahanike
    Ahanike Member Posts: 3
    edited April 6

    Doesn't a system administrator a machine have the same admin permissions to install application as a local account admin and the rest of admin permissions?

    I have also tried installing the firefox application from the list of softwares in the software section and that installs just fine.

  • mbudke
    mbudke Member Posts: 87 ✭✭✭

    SYSTEM is not exactly the same as a user since it misses some parts (e.g. profile settings and folders).
    For example you cannot login to a desktop with that user.

    I am not sure if it brings you to the solution but what you can try is:

    Within procmon you should be able to see the script running and the execution of the installer.
    Maybe this provides a bit more information at which steps it fails.