Unable to reach agent when running scripts

jstevens Member Posts: 3

We have been running in to a lot of agents that when we run a script, that has successfully run in the past, it gives an error message saying "Unable to reach agent". I have submitted a couple of tickets in the past but never get an answer as to why it happens. Any one else running in to this and maybe know the reason?


  • jstevens
    jstevens Member Posts: 3

    An update on this, I ran the script about 5 times with the "Unable to reach agent" result. I then ran it again and it worked. No one was using the agent during that time so nothing was changed on it. I would expect the script to run everytime.

  • frank.pietersma
    frank.pietersma Member Posts: 78 ✭✭✭

    I have experienced this issue before. In all cases clearing site data from internet browser fixed it. Not a very bright solution but it helps.
    I noticed that this behavior occurs much more often then it used to. Lately I even encountered an issue where I could not connect to the remote agents and clearing browser data solved the issue.
    Very annoying because I don't want to clear my browser data every 2 days just to keep Atera working. There are other things that I use in the browser which are affected by cleaning the browser,

    I discussed this with support and they advised to use a dedicated browser, just for Atera. Everytime on closing the browser always delete site data. Not really a solution but it seems Atera is very browser dependable and besides clearing the browser data there is no real solution for this,

  • Samuel MONIER
    Samuel MONIER Member Posts: 6

    Since the new UI, all scripts running more than 2 minutes will show that error.
    Now, we must go in Recent Processes to show the result.


  • jstevens
    jstevens Member Posts: 3

    Frank, thanks for the browser tips and will give that a try.

    Samuel, the error pops up immediately.

  • [Deleted User]
    [Deleted User] Posts: 0

    I am seeing this issue even on scripts that take less than 3 seconds to run!

    It gives the false error message straight away - even though it has actually successfully run the script.
    But as Atera refuse to list their known issues we are all left once again posting here to find out whether other people are having the same issue.

    The language on that help article is all wrong too, the message should read "The script exceeded the 2 minute maximum runtime for output, please see the recent processes report for the output." - it has nothing to do with "Unable to reach agent".

    Does anyone here remember the good old days when people used to test their software before they released it ?

  • Ahanike
    Ahanike Member Posts: 3

    Can that 2 minute time frame be extended to 10 minutes?