Private Software

slinke Member Posts: 9


I'm still finding it difficult, or rather it's not possible, to distribute and update my own software.
One example is the Securepoint VPN Client, which is now available in version 2.0.40, but is still version 2.0.36 at Chocolatey and the maintainer of the package is not responding.

However, a separate repository is associated with additional costs for JFrog and NuGet, or am I misunderstanding this?

I had read here at some point that Atera is probably also developing a new version, but there is probably nothing known here yet, is there?


  • mmarquez
    mmarquez Member Posts: 3

    If installing the latest version would override the earlier version, you can host the .exe or .msi file in the cloud (AWS / Azure) and then write a script in Atera that references this file and installs it on the back-end.

  • mjones
    mjones Member Posts: 143 ✭✭✭✭

    This is how I do it also, It's a bit more clunky than having a native file share from the RMM, but generally seems to work fine.

  • nina
    nina Administrator Posts: 428 admin

    Thanks @MJones and @mmarquez !!!

  • slinke
    slinke Member Posts: 9

    Thank you for your help.
    I had actually tried this at the very beginning, but then quickly gave up and thought it was because it was rolled out with the SYSTEM user. In fact, the problem was probably somewhere else.
    When I tried it again, it worked perfectly and I have now rolled out a lot of software with it.

    Thank you very much!